Data store downloads unavailable
Incident Report for Regrid
Resolved
This incident has been resolved.
Posted Aug 03, 2021 - 14:15 EDT
Identified
Data store downloads are temporarily unavailable. Please contact us at help@regrid.com if we can help accessing a data store purchase.
Posted Aug 03, 2021 - 11:02 EDT
This incident affected: Regrid.