Intermittent Unavailability for Regrid Property App and API

Incident Report for Regrid

Resolved

This incident has been resolved. Availability for the Regrid Property App and API has been restored. If you are having difficulties accessing the Regrid Property App or API please contact support - help@regrid.com
Posted Feb 19, 2026 - 12:11 EST

Monitoring

A fix has been implemented and we are monitoring the results
Posted Feb 19, 2026 - 12:03 EST

Investigating

We are currently experiencing issues that may cause access and/or performance issues for users of the Regrid Apps and API. We are currently working to investigate the cause and resolve the issue.
Posted Feb 19, 2026 - 11:53 EST
This incident affected: Regrid and Regrid API.